J’hopper’s Heaven (ジョッパーズヘブン)

ジョブホッパー・ボブがジョブホッパーでなくなる日を夢見るブログ

RabbitMQでEvent Exchangeプラグインを使うときに知っておきたいこと

_human & rabbit

おはよう!そして会えないときのためにこんにちは、こんばんは、そして、おやすみなさい。ジョブホッパー・ボブです。

RabbitMQでコンシューマーコネクションを可視化するために、Event Exchangeを使う必要が生まれたので、その時に調べたり確認したメモ。ただのメモ。

すべてのRabbitMQのバージョンで使えないぽい

Σ( ゚皿゚)ガーン RabbitMQ 3.5.4ではプラグインとして表示すらされない。rabbitmq3.6.0以上のバージョンじゃないとだめ。

プラグインを有効にする方法
$ sudo rabbitmq-plugins list
$ sudo rabbitmq-plugins enable rabbitmq_event_exchange
Compose(コンポーズ)では利用できない

Compose上で動くRabbitMQには、rabbitmq_event_exchangeプラグインは有効にできない。悲しみ。

help.compose.com

www.compose.com

/ 以外のvhostではエラーになる

適当なvhostで動作確認してたら、エラーが大量発生してうまくいかなかったので、この機能は、/ で利用できる機能なんだ、と言い聞かせてる。